Troubleshooting VCF Configuration Drifts
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Troubleshooting VCF Configuration Drifts

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Article ID: 367846

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Configuration Management allows you to view and monitor all VCF deployments and their configuration specifications in one place. This feature is a part of the new VCF admin console.

This article provides information about what could have gone wrong, troubleshooting tips, and information about contacting support.

Environment

VMware Aria Operations 8.18
VMware Cloud Foundation 5.2.x

Resolution

Table of Contents

Template Creation Section

Issue 1: A specific vCenter Server is not present in the drop-down list to extract the Configuration Settings during Step 2 of Create Config Template.

Possible causes:

 

Issue 2: Error occurred while retrieving Configuration Settings from the selected VC.

Possible causes:

Remediation:

 

Issue 3: Unable to view any Configuration Settings from the selected VC in the Config Template Preview pane.

Possible cause:

  • vCenter Server is registered with an account that does not have Administrator privileges in vCenter.
    • Solution: The user with which the vCenter server is registered with the cloud proxy must be part of the Administrators group in vCenter.

 

Drift Check Section

Issue 1: Drift Check Failed with error: "An internal error has occurred".

Possible Causes:

  • vCenter Server is not reachable from Cloud Proxy.
  • Config Module service is not running. (See Appendix on how to check if Config Module is running).

Remediation:

 

Issue 2: The Drift Check has been in progress for a long time.

Note: The user will be notified in the UI client with the message: Drift check in progress...

Possible Causes:

  • Multiple vCenter Server drifts may be triggered at the same time. The check will be completed only when all the vCenter drifts are completed.
  • The system failed to update the task status due to connectivity failure with the Cloud Proxy.

Remediation:

  • Retry Drift Check with fewer VCs selected once the currently running task fails after the configured timeout of one hour.

 

Overview Section

Issue: Several vCenter Servers have drift status as UNAVAILABLE.

Possible cause:
The vCenter Server drift status can be UNAVAILABLE for the reasons listed below:

If nothing from the remediations or information above helps to resolve your issue, please Contact Broadcom Support.

 

Appendix

How to check whether the Configuration Management Adapter is Healthy:

How to check whether VC is reachable and in Collecting state:

How to check whether the Config Module service is in running mode:

  1. Log into the Aria Operations Cloud Proxy node as root via SSH.
  2. Run the following command to see the status of the Config Module service: docker ps

Additional Information

For additional assistance - Contact Broadcom Support