Unable to install or update Automation Folders
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Article ID: 367809
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Updated On:
Products
Ghost Solution Suite
Deployment Solution
Issue/Introduction
Unable to install or upgrade an Automation folder on an endpoint machine.
Environment
Windows 10 or 11
GSS 3.3 RUx
DS 8.x
Cause
One cause of the issue is attributed to corrupt BDC.
Check to see if there is an error in BCD:
- To verify, run the following from an administrator command prompt:
bcdedit
- Check for:
parameter is incorrect
- If you see this then the BDC is corrupt and you will not be able to update or install Automation Folders.
The error can also be seen in C:\autoinst.log file:
- Scroll to the bottom of autoinst.log file and look for the error:
Exit code: 2 (EXIT_QUERY_NOT_INSTALLED)
And within the log file will be:
parameter is in correct
Resolution
A repair of BDC is required:
- To check if the System partition does not have an assigned driver letter run command with elevated privileges:
Diskpart
select disk 0
list volume
select volume (#)
this will the volume number of the system partition
<-- if the system partition does not have an assigned driver letter -->
assign letter=S
<--the windows partition should have assigned letter C -->
exit
Then, enter the command:
bcdboot c:\windows /s S: /f ALL
Example:
Diskpart
select disk 0
list volume
select volume 1
assign letter=S
exit
bcdboot c:\windows /s S: /f ALL
- Enter the following in an administrator command prompt:
bcdedit
There should NOT be:
parameter is incorrect
- Installing of the automation folder should now be successful.
- You should see in the BCD an entry for 'Symantec Automation Folders
- And in the latest autoinst.log (C:\autoinst.log) file should see:
Exit code: 0 (EXIT_SUCCESS)
at the bottom of the log files
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