DXS APM Experience Performance Solution for Large Experience Queries
search cancel

DXS APM Experience Performance Solution for Large Experience Queries

book

Article ID: 367802

calendar_today

Updated On:

Products

DX APM SaaS DX Application Performance Management

Issue/Introduction

Slow Performance on Experience Tile rendering. Fifteen seconds or more to render.

Environment

In tenancies that have:

  • Large number of agents
  • Large number of Metrics
  • Experience tiles created with Onboarding scripts
  • Large number of public Tiles shared across the tenancy

Cause

In the current DXS Experience, there no limit on the query made.

The onboard scripts created Experience cards that did not take this into consideration when run to create DXS APM Experience cards. 

Too large query in the tile can be slow.

Including a number of Universe Tiles as public can slow the overall Experience view slow.

Very large Applications in single tenancy.

Resolution

Options to consider:

  • Limit APM Experience Queries to small number of filters results based on testing in Metric View test before creating APM Experience card.
  • Consider impact before making APM Experience card public in from the APM Universe.
  • Create APM Universes that limit the agent or metric in an APM Universe so the APM Experience card based on the APM Universe has smaller more performant view.
  • Review the Application and look at breaking single application into smaller services based APM Universes. Like Application URL groups.
  • Test Experience card after creating to make sure it is performant.
  • Test Overview Enterprise/Application Universe view impact when landing on APM Experience Page to verify performance when Experiences are made public.
  • Create APM Universe Attributes to assist in organizing data into smaller more logical groups for Experience Cards.

Long Term:

Planned query limit Experience View check with support for updates.