/storage/var/log runs out of disk space due to QueryResultsCache.data file growing in Aria Operations for logs
book
Article ID: 367761
calendar_today
Updated On:
Products
VMware Aria Suite
Issue/Introduction
/storage/var/log runs out of disk space.
/storage/var/loginsight/cache/QueryResultsCache.data is several GB in size.
If /storage/var/log becomes full, the UI might not be accessible.
Cause
The file /storage/var/loginsight/cache/QueryResultsCache.data is growing to several GB in size.
Resolution
The following workaround can be applied:
Stop the Log Insight service (command: service loginsight stop)
Take a backup of the files "QueryResultsCache.lock" if present, and "QueryResultsCache.data" (files are in /storage/var/loginsight/cache/), or back up the full VM. Alternatively, you could take a snapshot of the VM and delete it later after verifying that there is no issue.
Delete "QueryResultsCache.data" using rm command. If not successful, delete both "QueryResultsCache.lock" and "QueryResultsCache.data".
Start the Log Insight service (command: service loginsight start)
The impact will be that the next queries won't make use of the cache. The cache file(s) will still be recreated on next query.