EEM install failures after multiple attempts
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EEM install failures after multiple attempts

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Article ID: 367681

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

When trying to install EEM on a dedicated server the installation is failing.
The installation has been attempted multiple times using the Autosys R12.x installer.

Environment

Autosys 12.X
RHEL 8
EEM 12.x

Cause

In the installation logs we see the following EEM error:
EEM Installation exit code ...245

Resolution

Perform a clean install of EEM using the ISO module EEM installer.

Steps to clean up
1) delete contents of the /tmp directory
2) remove all folders and subfolders from /opt/CA
3) remove /etc/profile.CA
4) check the /etc/init.d folder for any dxserevr or igateway scripts and remove them
5) delete the dsa user
6) delete the Group etrdir
4) reboot the machine
5) login as root and do an env to make sure there are not environment variables pointing to /opt/CA
6) validate the SE Linux is disabled or set to permissive mode.

If the only component you want to install is EEM on this machine then do the following
1) check the md5 hash on the ISO download
2) go to <iso>/modules/EEM/ and run the setup.bin
3) When this completes successfully follow the below to change the Certificate size to 2048
https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/autosys-workload-automation/12-1-01/securing/ca-eem-security-data-replication-backup-and-migration/configure-a-new-ca-eem-instance-with-existing-ca-wcc-security-policies/configure-ca-eem-for-root-certificates-generated-with-different-key-lengths.html