Saving favorited data sets in Zowe Explorer may result in an error
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Saving favorited data sets in Zowe Explorer may result in an error

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Article ID: 367666

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Updated On:

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Issue/Introduction

When opening a data set (or member) from the Favorites bar, the data set can't be saved. This results in a type error as shown in the screenshots below. However, after searching for a specific data set in the profile, the PDS is able to save successfully. After searching for another data set in the profile, saving the previously opened data set fails again.

It is also worth mentioning that after searching for a PDS, if a member of that PDS is open in the editor, the member cannot be saved until the PDS has been opened in the tree view.

Environment

Windows, VS Code, Zowe Explorer 2.15.4 or older

Cause

A custom Zowe Explorer temporary folder is defined in VS Code settings and set to a folder path with uppercase drive letter (e.g., "C:\Temp").

This does not match the way that VS Code handles paths on Windows, which is using a lowercase drive letter (e.g., "c:\Temp").

Resolution

Advise the user to update to Zowe Explorer 2.16.0 or newer, which fixes the error.

In case of being unable to upgrade, a workaround in older versions of Zowe Explorer is to change the temporary folder setting to use a lowercase drive letter:

Doesn't work (uppercase)

Works (lowercase)

Additional Information

Screenshots of error messages: