"Session Not Authenticated" Error When Managing vSAN in vSphere Client After vCenter Upgrade to 8.x
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"Session Not Authenticated" Error When Managing vSAN in vSphere Client After vCenter Upgrade to 8.x

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Article ID: 367591

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Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

Symptoms: 

  • vSAN Skyline Health alarms may be seen, such as:
    • vSAN cluster alarm "vSAN Cluster Configuration Consistency"
    • vSAN cluster alarm "vSAN daemon liveness"
    • vSAN physical disk alarm "Physical disk health retrieval issue"
    • vSAN performance service alarm "Performance service status"
    • vSAN hardware compatibility alarm: "Host issues retrieving hardware info"
  • Accessing functions, such as <Cluster> -> Configure -> Services or <Cluster> ->Configure -> Disk Management, display "Session Not authenticated" error:

  • You may see messages like this in the /var/log/vmware/vsan-health/vsanmgmtd.log on the vCenter server: 

2024-04-17T14:19:12.120-05:00 info vsanvcmgmtd[256466] [vSAN@6876 sub=vmomi.soapStub[4] opId=d836afeb] SOAP request returned HTTP failure; <<cs p:00007f67e00b1220, TCP:localhost:8085>, /sdk>, method: fetchVsanSharedSecret; code: 500(Internal Server Error); fault: (vim.fault.NoPermission) {
-->    faultCause = (vmodl.MethodFault) null,
-->    faultMessage = <unset>,
-->    object = 'vim.HostSystem:cdef2f69-xxxx-xxxx-xxxx-face92176c4b:host-345716',
-->    privilegeId = "Host.Config.Storage",
-->    missingPrivileges = (vim.fault.NoPermission.EntityPrivileges) [
-->       (vim.fault.NoPermission.EntityPrivileges) {
-->          entity = 'vim.host.VsanSystem:cdef2f69-xxxx-xxxx-xxxx-face92176c4b:vsanSystem-345716',
-->          privilegeIds = (string) [
-->             "Host.Config.Storage"
-->          ]
-->       }
-->    ]
-->    msg = "Received SOAP response fault from [<<cs p:00007f67e00b1220, TCP:localhost:8085>, /sdk>]: fetchVsanSharedSecret
--> Permission to perform this operation was denied."
--> }

Environment

After upgrade of vCenter 7.x to 8.x

Cause

A low-level permission role was assigned to a hidden group in the vCenter Database

Resolution

Please contact Broadcom support for assistance