The error, "Server is busy. Please try again later. If issue still persists, contact the system administrator." is seen when editing server cost drivers in Aria Operations
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The error, "Server is busy. Please try again later. If issue still persists, contact the system administrator." is seen when editing server cost drivers in Aria Operations

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Article ID: 367511

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

When attempting to edit the server cost drivers in Aria Operations it fails to save and gives the following error: "Server is busy. Please try again later. If issue still persists, contact the system administrator."

Environment

Entries in web.log:


2023-11-13T19:03:43,514+0000 INFO [ajp-nio-127.0.0.1-8009-exec-22] com.vmware.vcops.ui.util.MainPortalListener.log - No result defined for action com.vmware.vcops.ui.action.CostDriverAction and result input ( Url: /ui/costDriver.action Params: mainAction=saveServerGroups )

Cause

This issue is due to struts limitation of data being sent as payload. Struts framework has reduced the payload size to a much smaller value. Hence the save isn't working.

Resolution

An immediate workaround is to export the cost drivers, edit the spreadsheet, then re-import it. Here are the steps:

  1. From the left menu, click Configure > Cost Drivers > Cost Drivers tab. In the Cost Drivers tab, select either Import or Export.
  2. The import and export functionality is applicable only for vCenter cost drivers, the functionality is not available for VMware Cloud on Amazon Web Services.
  3. Using the import and export option, you can perform the following actions on the cost drivers:
  • Export or import the cost driver configuration file.
  • Read and edit the cost driver configuration file.
  • Validate the updated cost driver configuration file and report errors.
  • Identify the error from the log file and correct the errors.

You are prompted with error messages if the uploaded file has errors. You can correct the errors and upload the file, or you can ignore the errors, the system still allows you to upload the file.

If you want a more permanent workaround while using Aria Operations 8.18.x the following steps can be taken.

Take snapshots of the Aria Operations cluster.

  1. SSH to each vROPs node.
  2. Navigate to the appropriate directory.
    • cd /usr/lib/vmware-vcops/tomcat-web-app/webapps/ui/WEB-INF/classes/
  3. Make a backup of the struts.xml file.
    • cp struts.xml struts.xml.old
  4. Edit the struts.xml file.
    • vi struts.xml
  5. Modify the line shown below, changing the value from "16384" to "32678".
    • <constant name="struts.multipart.maxStringLength" value="16384"/> to <constant name="struts.multipart.maxStringLength" value="<32678>"/>
  6. Save and close the file.
  7. Restart the UI service on all the nodes.
    • service vmware-vcops-web restart
  8. Test the change by editing the value again in the UI.

This issue is permanently fixed in VCF 9.0.0.