The Portal interface is unresponsive in VMware Cloud Director Availability 4.x
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The Portal interface is unresponsive in VMware Cloud Director Availability 4.x

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Article ID: 367374

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Updated On:

Products

VMware Cloud Director Availability - Disaster Recovery 4.x VMware Cloud Director Availability - Migration 4.x

Issue/Introduction

When attempting to access the primary VMware Cloud Director Availability (vCDA) 4.x UI in a cloud site, the page does not load and a restart of the appliance is required to correct the behavior.

  • In the cloud service log directory (/opt/vmware/h4/cloud/log), there is a recent file with an hprof extension (e.g., java_pid1234.hprof).
  • Events have been configured for delivery to an external system in vCDA.

Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs if there are a high number of events, such as login failures, that cannot be immediately delivered or are scheduled to be delivered. These items can accumulate and consume sufficient memory to result in an out of memory error in VMware Cloud Director Availability. This results in the cloud service being unable to continue to process tasks correctly as well as failing to provide the portal interface. In this case, existing replications will not be interrupted.

Resolution

This issue is resolved in VMware Cloud Director Availability 4.7.1, available at the Broadcom Support Portal.

Additional Information

For more information regarding the upgrade process, please refer to the Upgrading in the Cloud Director site section of the VMware Cloud Director Availability documentation.