SRM upgraded to 8.8 then reverted to 8.6 or below
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SRM upgraded to 8.8 then reverted to 8.6 or below

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Article ID: 367371

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:


Error in the SRM GUI:
"SRM Server is unreachable"


vmware-dr.log shows messages similar to below:
[backtrace end]. Received SOAP response fault from [<SSL(<io_obj p:0x00007f3774059878, h:19, <TCP 'xx.xx.xx.xx : 50810'>, <TCP 'xx.xx.xx.xx : 443'>>), /sso-adminserver/sdk/nasalab.local>]: updateLocalSolutionUserDetails
Idm client exception: Object class violation

SRM will successfully register with the vCenter during a reconfigure.

Environment

VMware Site Recovery Manager 8.x

Cause

SRM 8.8 uses a Service Account, which is a different from the previous versions solution user.

Resolution

Remove the Service Account

Note: vCenter snapshots would be ideal. While this is a simple change, it is always helpful to take snapshots before making changes like this. If the wrong account is removed, we may cause additional problems.

  1. Connect to the vCenter server via Jxplorer
  2. Delete the SRM Service Account under "SolutionPrincipals" via Jxplorer
    • As an example, the solutionuser will look like this: h5-dr-sa-uuid 

  3. Reconfigure SRM through the VAMI on port 5480