Restore Domains job fails
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Restore Domains job fails

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Article ID: 367195

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The Restore Domains job fails with the following error in the bg-ca.log:

ERROR 2024-05-07 04:44:39,170 [Dispatch Restore Domains : bg@bg_server (tenant=clarity)] jaspersoft (clarity:user:session:Restore Domains) () Content import failed.
ERROR 2024-05-07 04:44:39,170 [Dispatch Restore Domains : bg@bg_server (tenant=clarity)] jaspersoft (clarity:user:session:Restore Domains) () Restore Domains Job Failed:  :: 
com.niku.union.reporting.jaspersoft.exception.JasperDomainException: Error in importing content
    at com.niku.reporting.jasper.ClarityJasperAdmin.jasperContent(ClarityJasperAdmin.java:918)
ERROR 2024-05-07 04:44:39,174 [Dispatch Restore Domains : bg@bg_server (tenant=clarity)] niku.njs (clarity:user:session:Restore Domains) () Error executing job: 5544022
java.lang.Exception: Restore Domains job Failed: Error in importing content
    at com.niku.reporting.jobs.jasper.RestoreJaspersoftDomainsJob.scheduledEventFired(RestoreJaspersoftDomainsJob.java:88)

When the 'admin content-jaspersoft csk restoreDomains -userName superuser -password superuser' command is issued directly from the command line, following error is thrown:

Failed to import content for tenant  : No space left on device
com.niku.nsa.service.ExecutableException: com.ca.jasper.restAdapter.JasperException: No space left on device
        at com.niku.reporting.jasper.importexport.JasperContentCommand.execute(JasperContentCommand.java:245)

Cause

Lack of hard disk space in the application server that executes the 'Restore Domains' job.

Resolution

Add space to the server, or cleanup files / folders consuming space unnecessarily.