Error in aggregator logs show queue is full.
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Error in aggregator logs show queue is full.

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Article ID: 367193

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Updated On:

Products

Data Loss Prevention Endpoint Prevent Data Loss Prevention

Issue/Introduction

While viewing MonitorController#.log or Aggregator#.log you notice an error in the logs that say that the queue is full. 

Environment

com.symantec.dlp.communications.monitorcontroller.applications.subsystems.MonitorControllerAgentAttributeValuesForwarderSubsystem ensureQueueNotFull
FINE: Agent attributes forwarder suspending the agent with name '<hostname>' as the queue is full (from ensureQueueNotFull()).

Cause

MaxQueuesize on Aggregator.properties is too low for the current agent communication traffic. 

Resolution

Locate the following setting in Aggregator.properties


Windows: <drive>:\Program Files\Symantec\DataLossPrevention\DetectionServer\<version>\Protect\config
Linux: \vvar\Symantec\DataLossPrevention\DetectionServer\<version>\Protect\config

# Maximum number of operations that can be pushed out across all transport connections.
# Exceeding this maximum will cause the transport connection write to block until operations
# are processed and the queue size returns to normal.
maxQueueSize = 5000

Set maxQueuesize=50000