The IT PAM agent suddenly stops after start-up
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The IT PAM agent suddenly stops after start-up

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Article ID: 367066

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After installing or upgrading an agent, the agent starts, but suddenly stops and the following errors can be seen after enabling the logs in DEBUG mode. 

 

 INFO   | jvm 1    | 2024/03/30 18:56:48 | Exception in thread "CA Agent Startup" java.lang.NoClassDefFoundError: org/bouncycastle/jcajce/provider/BouncyCastleFipsProvider
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  at java.lang.Class.getDeclaredMethods0(Native Method)
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  at java.lang.Class.getDeclaredMethod(Class.java:2128)
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  at netx.jnlp.Launcher.launchApplication(Launcher.java:299)
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  at netx.jnlp.Launcher$TgThread.run(Launcher.java:466)
 INFO   | jvm 1    | 2024/03/30 18:56:48 | Caused by: java.lang.ClassNotFoundException: org.bouncycastle.jcajce.provider.BouncyCastleFipsProvider
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  at netx.jnlp.runtime.JNLPClassLoader.loadClassExt(JNLPClassLoader.java:541)
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  at netx.jnlp.runtime.JNLPClassLoader.loadClass(JNLPClassLoader.java:498)
 INFO   | jvm 1    | 2024/03/30 18:56:48 |  ... 5 more

Environment

CA Process Automation 4.4.2

Cause

The cause for this could be the installation of 4.4 which did not happen with proper admin rights or the file(SystemRepositoryData.xml) is opened/in use which leads to acquire a lock on this file and preventing the update to happen. 

Resolution

1) Re-install 4.4.0
2) Re-install sdm/cmdb connectors
3) Re-install 4.4.2

As the agents are already installed, need not install them again.

Restart of the services will create a new SystemRepositoryData.xml file.