Error: "UnicodeDecodeError: 'utf-8' codec can't decode byte" When Running Host-based Firewall Import Script
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Error: "UnicodeDecodeError: 'utf-8' codec can't decode byte" When Running Host-based Firewall Import Script

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Article ID: 366993

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Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense)

Issue/Introduction

Using the Host-based Firewall Import/Migration Script prompts the error: "UnicodeDecodeError: 'utf-8' codec can't decode byte ... in position ...: invalid start byte"

Environment

  • Windows 11: All versions
  • Carbon Black Cloud: All versions
    • Host-based Firewall
    • Host-based Firewall Import Script

Cause

The windows OS language is set to something other than English and cannot decode in UTF-8.

Resolution

Change system language to English:

  1. Go to Windows Settings
  2. Time & language
  3. Language & region
  4. Administrative language settings
  5. Change system locale to "English" in some form
  6. Check Beta: Use Unicode UTF-8 for worldwide language Support
  7. Save settings and reboot.
  8. Attempt the import script again.