Unable to view "Top Contributors" in vSAN performance graphs
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Unable to view "Top Contributors" in vSAN performance graphs

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Article ID: 366976

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Updated On:

Products

VMware vSAN

Issue/Introduction

When going to Cluster > Monitor > vSAN > Performance and change to "Top Contributors" Once you click on the graph to load Top contributing VMs for that time, The VM list will not load and an error will be seen "Failed to extract the requested data. Check vSphere Client logs for details." 

This issue occurs with domain accounts
This issue will not occur with [email protected] 

Environment

VMware vSAN 

Cause

Users do not have the correct permissions or is not part of the ServiceProviderUsers group 

Resolution

Add domain user(s) to the ServiceProviderUsers group in vCenter. To confirm users are part of the ServiceProviderUsers group and to add users follow the below steps.

  1. In vCenter Web Client click on the hamburger menu in the upper left and navigate to Administration > Single Sign On > Users and Groups
  2. Select the "Groups" tab and look for ServiceProviderUsers
    Note: There may be multiple pages of groups and ServiceProviderUsers may not be on the first page, be sure to check all pages to find the group.
  3. Select the "ServiceProviderUsers" group
  4. Click Edit
  5. In the Edit Group window use "Add a member" to add members to this group.