Expiration date not updated on ISG Proxy running SSP/ISG Hypervisor
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Expiration date not updated on ISG Proxy running SSP/ISG Hypervisor

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Article ID: 366859

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Updated On:

Products

SSP SSP-S210 PLATFORM SSP-S410 SSP-S410 PLATFORM ISG Proxy

Issue/Introduction

Customer extended it’s license with Sales for ISG Proxy, but the expiration date does not reflect the end date of My Entitlements on SGOS.

ISG Proxy is still showing the old expiration date for the license

Environment

  • HYPERVISOR: SSP-S410, SSP-S210 running ISG Hypervisor 
  • PRODUCT: ISG PROXY
  • SGOS VERSION: 7.3.15.1

Cause

  • new license has not been downloaded from the ISG Hypervisor automatically
  • Proxy ISG has license auto-update feature disabled

Resolution

STEP1

Update the ISG PROXY license from the SSP/ISG Hypervisor via CLI:

 

If the SSP/ISG has connectivity to Internet

  • update the SSP trust-packages (ISG admin guide, page43)
  • SSP# ssl trust-package download-now
  • SSP# ssl trust-package view
  • load the license with an online update (no need to type the username/password if license has been already installed)
  • SSP# config t
  • SSP(config)# licensing view
  • SSP(config)# licensing load id <isg-proxy-license-sn>
  • check what ISG deployed applications uses the license
  • SSP(config)# applications view
  • enable auto-update feature on ISG so licenses should be automatically updated whenever there’s a change in My Entitlements
  • SSP# config t
  • SSP(config)# licensing
  • SSP(config-licensing)# auto-update true
  • (OPTIONAL) assign label to running application
  • SSP# config t
  • SSP(config)# applications view
  • SSP(config)# licensing view
  • SSP(config)# licensing
  • SSP(config-licensing)# edit id <isg-proxy-license-sn> label <application-name>
  •  

 

If the SSP/ISG has no connectivity to Internet

  • Please go to Broadcom Support Portal > My Entitlements > Site ID > ISG Proxy > License and download the license file at the bottom of the site with the passphrase ex. password123
  • Then please force the update of license manually using the content of license file
  • SSP# config t
  • SSP(config)# licensing
  • SSP(config)# licensing view
  • SSP(config-licensing)# inline force passphrase <password>
  • <paste the license file content for the ISG Proxy>
  • CTRL+D
  • If the result was OK, please check license view
  • SSP(config)# licensing view
  • (OPTIONAL) assign label to running application
  • SSP# config t
  • SSP(config)# applications view
  • SSP(config)# licensing view
  • SSP(config)# licensing
  • SSP(config-licensing)# edit id <isg-proxy-license-sn> label <application-name>

 

STEP2

Force the update on the ISG Proxy and enable auto-update to fetch the license from SSP/ISG Hypervisor whenever changed via CLI:

  • ISGPROXY> enable
  • ISGPROXY# config
  • ISGPROXY(config)# license-key auto-update enable
  • ISGPROXY(config)# exit
  • ISGPROXY# licensing update-key force

Additional Information

PLEASE NOTE: ISG Hypervisor license is not required to be updated before updating ISG Proxy or ISG CAS licenses