License Expiration date not updated on the Edge SWG (ProxySG) application running on ISG
search cancel

License Expiration date not updated on the Edge SWG (ProxySG) application running on ISG

book

Article ID: 366859

calendar_today

Updated On:

Products

SSP SSP-S210 PLATFORM SSP-S410 SSP-S410 PLATFORM ISG Proxy

Issue/Introduction

The license for the Edge SWG (ProxySG) application has been updated, but the expiration date on the Edge SWG (ProxySG) application does not reflect the new end date displayed on the "My Entitlements" page from the Broadcom Support Portal.

The Edge SWG (ProxySG) application shows the old license expiration date.

Environment

  • Platform: SSP-S410, SSP-S210 running ISG
  • PRODUCT: Edge SWG (ProxySG) application
  • SGOS VERSION: 7.3.15.1

Cause

The new license has not been updated on the ISG.

The ISG has the license auto-update feature disabled.

Resolution

To resolve this issue you must:

  1. Update the Edge SWG (ProxySG) license on the ISG
  2. Force the update on the Edge SWG (ProxySG) application and enable auto-update to fetch the license from the ISG when updated

1. Update the Edge SWG (ProxySG) license from the ISG via CLI

If the SSP/ISG has connectivity to Internet

  1. Update the SSP trust-packages (ssl trust-package)
    • SSP# ssl trust-package download-now
    • SSP# ssl trust-package view
  2. Load the license with an online update (no need to type the username/password if license is already installed)
    • SSP# config t
    • SSP(config)# licensing view
    • SSP(config)# licensing load id <isg-proxy-license-sn>
  3. Check which ISG applications use the license
    • SSP(config)# applications view
  4. enable auto-update feature on ISG so licensing will be automatically updated whenever there’s a change in "My Entitlements" from the Broadcom Support Portal
    • SSP# config t
    • SSP(config)# licensing
    • SSP(config-licensing)# auto-update true
  5. (OPTIONAL) assign labels to running applications
    1. SSP# config t
    2. SSP(config)# applications view
    3. SSP(config)# licensing view
    4. SSP(config)# licensing
    5. SSP(config-licensing)# edit id <isg-proxy-license-sn> label <application-name>

If the SSP/ISG has no connectivity to Internet

  1. Go to the Broadcom Support Portal > My Entitlements > Site ID > ISG Proxy > License and download the license file at the bottom of the site with a passphrase, for example: password123
  2. Force the update of license manually using the content of license file
    • SSP# config t
    • SSP(config)# licensing
    • SSP(config)# licensing view
    • SSP(config-licensing)# inline force passphrase <password>
    • <paste the license file content for the ISG Proxy>
    • CTRL+D
    • If the result was OK, please check license view
    • SSP(config)# licensing view
  3. (OPTIONAL) assign labels to running applications
    • SSP# config t
    • SSP(config)# applications view
    • SSP(config)# licensing view
    • SSP(config)# licensing
    • SSP(config-licensing)# edit id <isg-proxy-license-sn> label <application-name>

Force the update on the Edge SWG (ProxySG) application and enable auto-update to fetch the license from the ISG whenever it's changed via CLI

From the Edge SWG (ProxySG) application CLI execute the following:

  • ISGPROXY> enable
  • ISGPROXY# config
  • ISGPROXY(config)# license-key auto-update enable
  • ISGPROXY(config)# exit
  • ISGPROXY# licensing update-key force

Additional Information

NOTE: The ISG license is not required to be updated before updating Edge SWG (ProxySG) or CAS application licenses