Unable to Create a Alarm Policy
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Unable to Create a Alarm Policy

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Article ID: 366854

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Updated On:

Products

Spectrum

Issue/Introduction

In the utilities menu on a device there is a "Schedule Alarm Policy" menu. How do I enable this to create a policy?

Environment

DX NetOps Spectrum 22.x, 23.x

Cause

The functionality to create AlarmPolicies is disable by default.

Resolution

You need to set this parameter to true in the $SPECROOT/tomcat/webapps/spectrum/web.xml file and restart tomcat for the "Create Policy" button to be enabled when you select "Schedule Alarm Policy" from the device.  

<context-param xmlns="">
    <param-name>com.aprisma.alarm.deviceAlarmFiltering</param-name>
    <param-value>true</param-value>
    <description>This parameter is to enable or disable device alarm filtering.
        If the value is false, Add policy button will not be visible on "Alarm Filtering Information" section on "Information" tab of device model
        and create button for policy is disabled on "Select Policy And Schedule" dialog. To open this dialog, do right click on device and select "Schedule Alarm Policy..."</description>

Then you can create a alarm policy/filter to filter out alarms for a specific time.