NetApp servers are writing an error in their logs indicating that the Protection Engine server is too busy to accept scan requests
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NetApp servers are writing an error in their logs indicating that the Protection Engine server is too busy to accept scan requests

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Article ID: 366733

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Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

NetApp servers are reporting errors that Protection Engine (SPE) servers are not accepting scan requests. You may see an error similar to the following:


host_node: Linux_Server_Name

bp_alarm_message: For Vserver "Linux_Server_Name", AV server "10.x.x.x" is too busy to accept new scan requests.

description: <3>Apr  4 14:54:16 [Linux_Server_Name:Nblade.vscanConnBackPressure:error]: For Vserver "Linux_Server_Name", AV server "10.x.x.x" is too busy to accept new scan requests.

start time: 2024-04-04 14:55:00

source: oim.prod_netapp

Environment

Protection Engine 8.x, 9.x

Cause

The maximum number of active threads (MaxThreads) was set higher than the physical resources could handle. This can result in the available cores becoming saturated.

Due to the maximum threads not being met or exceeded, new/incoming scan requests were not queued. This may have caused a delay which resulted in the application timing out and reporting it as the error above.

 

Resolution

Configure MinThreads and MaxThreads according to the SPE Tuning Guide:   

1. On the SPE server open an administrative Command Prompt:

2. CD "C:\Program Files\Symantec\Scan Engine"

3. Run the following commands individually:

xmlmodifier -s //configuration/Resources/System/MinThreads/@value 8 configuration.xml


xmlmodifier -s //configuration/Resources/System/MaxThreads/@value 24 configuration.xml

4. Restart the Symantec Protection Engine service