Installer Fails - SQL Server Port 1433 Connection Refused

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Article ID: 36555

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

Issue:

When running the RA installation wizard, the step to connect to the database fails with the following error:

Can't connect to SQL Server DB. Error: The TCP/IP connection to the host [IP address], port 1433 has failed. Error: "Connection refused: connect. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall."

 

Environment: 

Windows Server running Microsoft SQL Server.

 

Cause:

SQL Server was not configured to allow TCP/IP connections from the client's IP address.
 
 

Resolution:

  1. Open the SQL Server Configuration Manager.
  2. Expand SQL Server Network Configuration for the server instance in question.
  3. Double-click "TCP/IP".
  4. Under the "Protocol" section, set "Enabled" to "Yes".
  5. Under the "IP Addresses" section, set the TCP port under "IPAII" (which is 1433 by default), find the IP address of the client the installation wizard is being run on, and set both "Enabled" and "Active" to "Yes".

Environment

Release: NOLNAC99000-5.5-Nolio-Automation Center
Component: