Spectrum Connector Offline

book

Article ID: 36537

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum connector is showing offline.

 

 

Cause

Verify ..CA\SOI\log\SpectrumIM_Connector_<Connector_Name>.log

If it shows following
-------- 
[CA:[email protected]],01-15-16 06:54:28,ERROR initialize :3414 Could not to connect to model domain on XXXXX
[CA:[email protected]],01-15-16 06:54:28,ERROR initialize :3436 Failed to Initialize the Connector: 
java.lang.Exception: Could not connect to spectroSERVER britwvimapp01. Bad Host entry or spectroSERVER is not running. 
at com.ca.usm.ucf.spectrum.SpectrumSilo.initialize(SpectrumSilo.java:3419) 
at com.ca.usm.ucf.spectrum.SpectrumUCFConnector.initialize(SpectrumUCFConnector.java:101) 
at com.ca.sam.ifw.framework.Silo.Initialize(Silo.java:308) 
at com.ca.sam.ifw.framework.Silo.siloInitialize(Silo.java:500) 
at com.ca.sam.ifw.framework.Connector$8.run(Connector.java:2688) 
---------

Which means connector has problem to connect to SpectroSERVER

Environment

SOI integrated with Spectrum via Spectrum connector.
 

Resolution

Verify if your SpectroSERVER is running or not.

If the SpectroSERVER is not running:


- Stop Spectrum connector from services.msc
 > CA SAM Integration Services
 > CA SAM Event Management
- Start SpectroSERVER
- Clean Spectrum connector cache ..CA\SOI\lib\ivy\configuration\org.eclipse.osgi
- Start Spectrum connector 

If the SpectroSERVER is running:

- Check ports to ensure nothing is being blocked between the SpectroSERVER and the Spectrum connector systems
- Ensure the Spectrum connector system is added Spectrum's 'Host Security' (.hostrc) file
- Ensure the user used to installed and run the Spectrum connector is a valid Spectrum user in the SpectroSERVER database

Additional Information