Issue:
After running CA Workload Automation Restart Option for z/OS Schedulers (called CA 11) jobs AL7AD1 and AL7AD2 to install new CA 11 databases and files into the CA Datacom/AD version 14.0 Multi-User Facility (called MUF), an error message was displayed:
U11D-8650-1 DATACOM CMD=RDUKX TBL=HST RC=14(048) KEY=CAL7 JOB=jjjjjjjj
Even with this error, neither the MUF nor the CA 11 task failed, and the job kept running.
Cause:
The RC 14(048) message indicates that the Global History record in the HST (History) table was not found. The AL7AD1 and AL7AD2 members are used to create a new set of databases in this MUF, and will also allocate and initialize the empty database files. Since these tables are all empty, any job that tries to read this record will produce this error. If you are running the AL7TEST member, then the RC 14(048) is expected because the table is empty.
Resolution:
Once jobs with RMS steps have been processed by the CA 11 task, this Global History record will be added to the table.
Additional Information:
If further assistance is needed to resolve this problem, please run the following job and attach it to a support case for the CA Datacom/AD product:
//*
//JCL JCLLIB ORDER=(CAI.NEWCHLQ.CUSPROC) <== CHANGE AS NEEDED
//*
//DBUTLTY EXEC PGM=DBUTLTY,REGION=6M,PARM='/PGMDT=20010101'
// INCLUDE MEMBER=B14STLIB
// INCLUDE MEMBER=B14DDOUT
//*
//SYSIN DD *
SET OPTION1=ON-ERROR-CONTINUE
SET OPTION1=DUMPPGM=DBSIDPR
REPORT MEMORY=MVS
REPORT AREA=CXX,DBID=601
AUTOINFO DDNAME=INFOFILE
/*
//INFOFILE DD DUMMY
//
As always, please contact CA Technologies support for CA Datacom if you have further questions.