After installing WAMUI 12:52 sp1 CR02 objects are no longer accessible
search cancel

After installing WAMUI 12:52 sp1 CR02 objects are no longer accessible

book

Article ID: 36527

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

Issue:

After installing the  ADMIN UI 12:52 sp1 CR002 it is  longer possible to access the objects configured.
Every attempt at accessing an object results in a message about
 
Error; java.lang.NullPointerException
 
In the server.log and boot.log from JBOSS there are many errors like the following
 
2015-11-27 10:43:44,679 ERROR [ims.rules] (http-cosilsp01.inailservizi.inail.pri%2F10.1.61.119-8443-1) A number format exception was encounter transforming the values to longs for comparison. The values were [] and [1]. Returning false on evaluation. 

2015-11-27 10:43:59,127 ERROR [ims.ui] (http-cosilsp01.inailservizi.inail.pri%2F10.1.61.119-8443-4) java.lang.NullPointerException java.lang.NullPointerException at com.ca.siteminder.webadmin.tabhandler.SiteMinderTabHandler.initialize(Unknown Source) 
 
This is not an upgrade of the UI from a previous installation, but a new installation altogether
 

Environment: 

Operating System:  Windows 2008 R2 
Policy Server: 12.52 sp1 cr002 
Adminui: 12.52 sp1 cr002 
Java  version: JDK1.7_76 32bit 

 

 

Cause:

This is a common error when doing a full upgrade from version 12.52 to 12.52 SP1 , which has a different schema for the policy store, which requires upgrading the Policy Store besides the product itself. In particular, version 12.52 SP1  contains element “AdvAuthInstallationType” in the policy store which is missing in the 12.52 Policy Store. The null pointer exception is (most likely) happening due to missing element in the 12.52 Policy Store when trying to access it from a 12.52 SP1 AdminUI
 
Even thouogh in this case, the AdminUi is a new installation in 12.52 SP1, the Policy Store is still likely the old one from a 12.52 installation and it has not bee properly upgraded to the 12.52 SP1 structure. Therefore, doing so resolves the problem.
 
 

 

Resolution: 

This may be resolved by carrying out the following steps
1. Stop all policy servers. 
2. If policy store replications are enabled , disable it. 
3. Stop Admin UI 
4. Then, import data dictionary and default policy objects ,followed by XPSSweeper run. 
XPSDDInstall SmMaster.xdd 
XPSImport smpolicy.xml -npass 
XPSSweeper
5. Start PS 
6. Start Admin UI and test. 
 

 

 

Environment

Release:
Component: SMAUI