APM WebView Performance Agent does not show up under Investigator

book

Article ID: 36525

calendar_today

Updated On:

Products

APP PERF MANAGEMENT CA Application Performance Management Agent (APM / Wily / Introscope) CUSTOMER EXPERIENCE MANAGER INTROSCOPE

Issue/Introduction

 Problem:

 The IntroscopeWebView Agent node doesn't show up after following all the steps defined from the Guide:

 https://docops.ca.com/ca-apm/10-1/en/administrating/user-interface-configuration/configure-webview-options/configure-and-monitor-apm-webview-performance

 

 And the following error and warning messages show up on the Logs:

 IntroscopeWebView.log:

 [ERROR] [WebServer.RemoteClientConnectionManager] Unable to connect to EM

 IntroscopeAgent.log

 [WARN] [IntroscopeAgent.ConnectionThread] Failed to connect to the Introscope Enterprise Manager

 

 Environment:

 APM 10.1

 IntroscopeWebview Server is installed on the MOM Enterprise Manager system.

 

 Cause:

 Enterprise Manager Settings are not defined on the WebView Agent side.

 

 Resolution:

 Make sure the Enterprise Manager settings are defined in the IntroscopeAgent.profile.

 This is not mentioned in the CA APM Guide.

introscope.agent.enterprisemanager.transport.tcp.host.DEFAULT=
introscope.agent.enterprisemanager.transport.tcp.port.DEFAULT=
introscope.agent.enterprisemanager.transport.tcp.socketfactory.DEFAULT=

 

 

 

 

Environment

Release: CEMUGD00200-9.7-Introscope to CA Application-Performance Management-Upgrade Main
Component: