Problem:
Jboss server doe not start due Error...
Deployment "vfsfile:/C:/jboss-5.1.0.GA/server/default/deploy/iam_im.ear/"
is in error due to the following reason(s): java.lang.IllegalStateException:
Did not load correct number of messages, wanted:9 but got:8
Environment:
IDM 12.6 SP4
Windows 2008
Cause:
IAM Transaction Log growing too large without maintenance.
The issue can appear after a "Failure obtaining db row lock" due to 'IAM' Transaction Log Registry being full.
Resolution :
1. Reduce the the 'IAM' Transaction Log by running a shrink command into MSSQL database (please contact your Database Administrator for assistance).
2. Stop jboss service and Delete the /work and /tmp folder from jboss/server/default
3. Stop jboss service and
delete the "<jboss_home>\jboss-5.1.0.GA\server\default\data" directory.
4. Then start Jboss service.
Additional Information:
Title: Information regarding object store tables: object12_5 and lock12_5
Title: How to clear Provisioning Server notification queue (inbound synchronization)
https://support.ca.com/irj/portal/kbtech?docid=593173&searchID=TEC593173&fromKBResultsScreen=T
Title: How to Manage Identity Manager Tasks Stuck In-Progress.
https://support.ca.com/irj/portal/kbtech?docid=498092&searchID=TEC498092&fromKBResultsScreen=T