DDFBLD0151 HEADER TRANSACTION MISSING error message on CATALOG
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DDFBLD0151 HEADER TRANSACTION MISSING error message on CATALOG

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Article ID: 36174

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Updated On:

Products

Datacom DATACOM - AD CIS COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS COMMON PRODUCT SERVICES COMPONENT Common Services CA ECOMETER SERVER COMPONENT FOC Easytrieve Report Generator for Common Services INFOCAI MAINTENANCE IPC UNICENTER JCLCHECK COMMON COMPONENT Mainframe VM Product Manager CHORUS SOFTWARE MANAGER CA ON DEMAND PORTAL CA Service Desk Manager - Unified Self Service PAM CLIENT FOR LINUX ON MAINFRAME MAINFRAME CONNECTOR FOR LINUX ON MAINFRAME GRAPHICAL MANAGEMENT INTERFACE WEB ADMINISTRATOR FOR TOP SECRET Xpertware

Issue/Introduction

Issue:

After making changes to a CA Datacom/DB database definition, we then tried to run a batch job using DDUPDATE to catalog the definition to the Directory (CXX). While running this command:
-CXX CATALOG DATABASE,SCD-ACTIVITY-DB(PROD)

This error was produced:
TRANSACTION ERROR:  DDFBLD0151    HEADER TRANSACTION MISSING

Cause:

The likely reason for receiving this error message is that the program DDUPDATE was used instead of DDCFBLD. The -CXX CATALOG... function is used only in DDCFBLD. DDUPDATE is a common program used for most DBA functions, so it is an easy mistake to make.

Resolution/Workaround:

There are two options to resolve this problem:

1.    Change the Program name (EXEC PGM=) to DDCFBLD, or

2.    Use the –UPD DATABASE…, 1000 CATALOG, -END functions with the DDUPDATE program. See below for more details about this option.

Additional Information:

For more information about cataloging a database definition to the Directory (CXX), please refer to TEC1047513, titled “Options for cataloging a CA Datacom/DB database definition to the Directory (CXX).”

As always, please contact CA Technologies support for CA Datacom if you have further questions.

Environment

Release:
Component: DB