Problem:
EEM Reporting Utility installation on an EEM server is failing with the following errors:
C:\Program Files (x86)\CA\SC\eem_reporting_service>setup
Launching CA ERU setup...
Verifying CA EEM installation...
#FATAL: Unable to determine the location of a CA EEM installation.
Setup stopped.
java.lang.IndexOutOfBoundsException: Unable to determine the location of a CA EEM installation.
at com.ca.eru.util.Server.location(Server.java:28)
at com.ca.eru.service.ServiceSetup.verifyInstallation(ServiceSetup.java:72)
at com.ca.eru.service.Service.setup(Service.java:145)
at com.ca.eru.service.Service.main(Service.java:46)
Press any key to continue . . .
Environment:
Applicable to WAAE 11.3, 11.3.5 & 11.3.6 running on Windows 2008 64-bit environments.
Cause:
The EEM Reporting Utility installation checks the following registry key to determine the location of EEM installation:
HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\Embedded Entitlements Manager
However, on some Windows 2008 x64 versions, this registry key does not exist in the above location. Instead, it can be found in the following location:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\Embedded Entitlements Manager
This causes the EEM Reporting Utility installation to fail with the "Unable to determine the location of a CA EEM installation." error.
Resolution:
1. Launch 'regedit' utility and export the following registry key to a file:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\Embedded Entitlements Manager
2. Edit the exported registry file and remove 'Wow6432Node' from it.
3. Save the file.
4. Import the modified registry file using the 'regedit' utility.
5. Rerun the EEM Reporting Utility installation.
6. After successful EEM Reporting Utility installation, remove the newly added registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\Embedded Entitlements Manager
Note:
This will be addressed in a future release of the product.