SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceCA Service Desk ManagerCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
Issue:
We recently moved the Service Desk IMAP mailbox from Exchange 2003 to Exchange 2010. After the move, the maileater process was broken until we set the option "receive emails as plain text" on the mailbox. The issue now is that any email that is sent in Plain Text to the Service Desk mailbox is getting cut off. It's working fine for HTML emails.
Environment
-CA Service Desk Manager 17.x
-Microsoft Exchange Server 2007 or higher
Cause
-The library used by maileater requires the exact size of the message as it truncates the email after the received size
-By default, using IMAP on Exchange 2007 or higher will not send the exact message size
Resolution
-The resolution to this problem is to send the exact message size
-This can be done by setting the EnableExactRFC822Size option for IMAP to true in Exchange
-A workaround for this issue would be to use POP as the problem is exclusive to IMAP