Error occurred during the Uninstall SysEdge Agent, "CAM Client Registration Utility has stopped working"
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Error occurred during the Uninstall SysEdge Agent, "CAM Client Registration Utility has stopped working"

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Article ID: 36062

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Updated On:

Products

CA Server Automation CA Virtual Assurance for IM

Issue/Introduction

Problem:

When uninstalling the CA SystemEDGE agent using Add/Remove programs, an error occurs preventing the uninstall. 

<Please see attached file for image>

20160107_Error_Message.jpg

Cause:

The root cause of the problem is the Fault Module Name: MSVCR71.dll. If the Microsoft VC Visual C++ Redistributed package is removed, we have noticed the MSVCR71.dll module is also removed. Sub components of SystemEDGE, like CAM are dependent on this redistributed dll. Commands such as camstat.exe will fail to execute when this package goes missing, see below for steps to reproduce the problem.

*Note: This problem occurs because when CAM is installed it does not set the Dependency flag in the registry for this redistributed package. Future releases of CAM will be updated to set this dependency.

Steps to Reproduce:

  1. Execute camstat.exe which is located in the "C:\Program Files (x86)\CA\SC\CAM\bin\" directory and you will see this error generated
    "This application has failed to start because MSVCR71.dll was not found. Re-installing the application may fix this problem".

Workaround:

  1. Move a copy of file MSVCR71.DLL to the C:\Windows\SysWOW64 should contain, MSVCR71.DLL
  2. If you cannot find MSVCR71.DLL on the system, you can locate the dll from another system and copy it locally.
  3. Attached is a copy of the DLL msvcr71.zip

Environment

Release: SYSPAG99000-5.7-Systemedge
Component:

Attachments

1558722547730000036062_sktwi1f5rjvs16wil.jpeg get_app
1558534235579TEC1920495.zip get_app