NimRecorder has been disabled in latest version of Firefox.

book

Article ID: 35836

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

After the most recent update to Firefox (43.0.1), NimRecorder has been disabled by default in Firefox.

In the most recent update to Firefox (43.0.1), NimRecorder has been disabled in Firefox. 

I do not see an approved version available for the current version of Firefox.

e2e_appmon monitoring scripts that ran in FireFox no longer run and these web pages are no longer monitored

Cause

After the most recent update to Firefox (43.0.1), NimRecorder has been disabled by default in Firefox.

Environment

UIM Server:  any release 
e2e_appmon_dev:  any release

Resolution

In order to use Nimrecorder, you will have to manually enable it.

There is a way to enable the add-on for Nimrecorder from about:config 

Override add-on signing (advanced users): You can temporarily override this setting by changing the xpinstall.signatures.required preference to false in the Firefox Configuration Editor (about:config page). 

 

Open about:config:

In the Location bar, type about:config and press Enter.

  • The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.

Once you change the setting from true to false and relaunch Firefox, you will see the screen below for the nimrecorder extension.

Relaunch the Firefox browser.


For later releases of Firefix (starting with 5.7), the 5.2.551.1 versions of the NimRecorder is considered a legacy add-on and cannot be enabled in the Firefox browser.  You will see something similar to the following for this add-on:


NimRecorder could not be veriried for use in Firefox and has been disabled - legacy add-on disabled permanently

Access the Mozilla addons page and search for the NimRecorderNew addon at one of the following links:

https://addons.mozilla.org/en-US/firefox/search/?q=MozillaExt_NimRecorder.xpi&appver=57.0
https://addons.mozilla.org/en-US/firefox/addon/nimrecordernew/

Install this new NimRecorder add-on (version 6.0.1346) for use with your Firefox browser.

This should work for all Firefox browsers versions 57 and later.

Additional Information

Info From Mozilla web page: 
https://support.mozilla.org/en-US/kb/add-on-signing-in-firefox?as=u&utm_source=inproduct 

Attachments