Issue:
In the IntroscopeEnterpriseManager.logs you may find the info message: [PO:WatchedAgentPO Mailman 4] [Manager] TransactionTrace arrival buffer full,
discarding trace(s)" showing repeatedly. The issue is that you have a high volume of transaction traces and it is overloading the buffer.
Environment:
This is found in APM 10.1
Cause:
The system is producing a high volume of transaction traces.
Resolution:
You can increase the buffer size with the following parameter added to the IntroscopeEnterpriseManager.Properties file.
introscope.enterprisemanager.transactiontrace.arrivalbuffer.capacity=2500
The default is 2500, you can increase the value to 5000.
The only thing this will effect is the amount of heap in your JVM. Also review the performance of your environment, because a large amount
of transaction traces on your system may impact the performance