ACE probe appears stuck in endless configuration loop

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Article ID: 35718

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Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

The ACE probe may appear to be stuck in an endless configuration loop.  Customers using the deprecated SOC (Service-Oriented Configuration) template technology may notice that new templates fail to deploy.

 

Upon examining the ACE probe log, the following message will be seen repeating in a seemingly endless loop:

 

Nov 09 11:56:19:343 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later... 

Nov 09 12:01:19:893 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later... 

Nov 09 12:06:19:231 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later... 

Nov 09 12:11:19:219 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later... 

Nov 09 12:16:19:220 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later... 

Nov 09 12:21:20:885 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later... 

Nov 09 12:26:19:261 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later... 

Nov 09 12:31:19:139 WARN [attach_socket, com.nimsoft.probe.service.ace.Configurator] Configuration process already running. Will retry later...

 


 

Cause


This is caused by having records in CM_COMPUTER_SYSTEM for which the 'name' field is NULL.  The following query will return a positive result:

SELECT COUNT(*) FROM CM_COMPUTER_SYSTEM WHERE NAME IS NULL;
Ideally, this should return 0 rows; if it returns 1 or more rows it indicates that there is a problem with discovery populating device names.
 

Environment

Release: CNMSPP99000-7.6-Unified Infrastructure Mgmt-Server Pack-- On Prem
Component:

Resolution

Customers facing this problem should upgrade their UIM installation to 8.31 and then upgrade their discovery_server and agent probes to 8.32.
After the upgrade, it may be necessary to reset discovery to correct the device names. (See document kb000009544 for details on this process.)