After upgrading NFA my users no longer have access to Custom Reports or Custom Report Folders.

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Article ID: 35456

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA)

Issue/Introduction

Problem: 

After upgrading NFA to 9.3.1 or later, my users no longer have access to Custom Reports in NFA even if they have the "Manage Reports" role right.

Environment:  

9.3.1 and later

Cause: 

In order to support multi tenancy in NFA, the "Manage Reports" right is no longer treated as a superuser who has access to all reports by default.

Resolution/Workaround:

You must assign your users access to the new NFA Custom Reports Groups in CAPC/NPC

1. Login to NPC or CAPC.

2. Go to the Admin->Users page.

3. Edit a User account.

For NPC:

4a. Add the Custom Report group or groups under "/All Groups/System Groups/Data Sources/[email protected]/Custom Report Groups" like below:

<Please see attached file for image>

NFA_DataSourceGroup.png

<Please see attached file for image>

NFA_CustomGroup.png

For CAPC:

4b. Go to the "Access Permissions" and add the Custom Report group or groups under "/Inventory/Data Sources/[email protected]/Custom Report Groups" like below:

<Please see attached file for image>

CAPC_CustomReportGroups.png

 

5. Resync the NFA Data Source from the Admin->Data Sources page of NPC/CAPC, and allow the new rights to be pushed down to NFA and the user should have access to the Custom Report folder.

 

Additional Information:

NFA 9.3.1 Release Notes

 

 

Environment

Release:
Component: NQRACO

Attachments

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