Event Integration Connector offline in SOI

book

Article ID: 35435

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

Problem:

the Event Integration Connector for SOI does not come Online in the SOI Administration UI and SOI Console Connector Status UI

Environment:

SOI 3.3 CUM2

EI 3.0 + T373641

Cause:

The Event Integration Connector does not come online because it cannot identify the correct Client ID to connect to

the SOI Manager.

Error message seen in the ifw.log file:

INFO | jvm 1 | 2015/12/03 04:33:15 | tid:18 com.ca.eventplus.ifw.plugin.samadapter.SAMAdapter.reConnect: Reconnecting to IFW
INFO | jvm 1 | 2015/12/03 04:33:15 | tid:18 IFW ReConnection failed.Unable to connect using the provided client ID : reqClient_EI<connector name>_Publisher
INFO | jvm 1 | 2015/12/03 04:33:15 | tid:18 com.ca.eventplus.ifw.plugin.samadapter.SAMAdapter.SendEventToDestination: Reconnect failed return false -- Can't send Event
INFO | jvm 1 | 2015/12/03 04:33:15 | tid:18 com.ca.eventplus.ifw.common.StoreForward.storeEvent: Event Send failure: Storing RETRYABLE Event of Type:SAMAdapter

Workaround:

1. Go to <EI-HOME>/Ifw folder.
2. Create a new folder resources.
3. Paste attached file "log4j.xml" under resources folder.
4. Open Ifw/conf/wrapper.conf file. Add below line below wrapper.java.additional.5 wrapper.java.additional.6=-DIFW_RESOURCES="C:\Program Files (x86)\CA\Event Integration\Ifw"

log4j.xml

Environment

Release: SDBSEI99000-1.2-Spectrum-Device Based Suite-Event Integration Module
Component:

Attachments

1558534202745TEC1072442.zip get_app