CA Web Viewer 12.1 cannot connect to an Oracle 12c or 12g database.

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Article ID: 35385

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Updated On:

Products

CA Output Management Document Viewer CA Output Management Web Viewer

Issue/Introduction

CA Output Management Web Viewer 12.1 cannot connect to an Oracle 12c or 12g database. When using the configuration tool, the database connection test fails. The ConfigTool.log shows an exception with message:

   Loaded: ojdbc14.jar
 java.sql.SQLException: ORA-28040: No matching authentication protocol

When accessing Web Viewer, the web login page reports error
"Database connection can not be established. Contact your System Administrator.".

The wvtrace.log shows an exception with the same message:
Internal Exception: java.sql.SQLException: ORA-28040: No matching authentication protocol



Cause

The problem is caused by an older Oracle JDBC JAR file delivered with Web Viewer. 

 

Environment

Release: CA Output Management Web Viewer 12.1

Component: WBVLUW

Oracle Database 12c and 12g

Resolution

RO87675 CUMULATIVE BUILD 137 FOR V12.1 or higher contains support for Oracle Database 12c and 12g.


WORKAROUND:

Deleting this JAR file (in two places) resolves the problem.

For the Configuration Tool: 

 1. Locate the configuration tool folder. This is <install_target>/util

 2. Under util, open the jdbc folder.

 3. Delete file ojdbc14.jar 

 For Web Viewer (web interface):

1. Locate the deployed files for the CAOMWebViewer12 application under your web server.

    For Apache Tomcat, <catalina_base>/webapps/CAOMWebViewer12

    For IBM WebSphere, <application_server>/InstalledApps/...

    /CAOMWebViewer12_ear.ear/CAOMWebViewer12.war

 2. Under the folder, open the WEB-INF/lib folder.

 3. Delete file ojdbc14.jar 


Please note that after maintenance is applied and/or you re-deploy the WAR/EAR file, you must perform the circumvention again as the maintenance will restore the deleted file.