AHD04407:CA Service Desk Manager html generation error. Could not find or process 'wspmain.htmpl'.

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Article ID: 35382

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Problem:

 Errors when logging into Web Screen Painter:

-AHD04407:CA Service Desk Manager html generation error. Could not find or process 'wspmain.htmpl'.

-AHD04714:Unable to open file wspmain.htmpl at ?: No such file or directory (2) userid=ServiceDesk

 

Cause:

There is role assigned to the user that has the "Web User Interface Type" option set to none.

 

Resolution:

Change the configuration of the role and set a "Web User Interface Type". Please follow the steps below:

1) Go to Administration

2) Security and Role Management > Role Management > Role List

3) Click on the Role > Additional Information > Web Interface > Web User Interface Type

4) Set the option to something different than <none>

5) Save changes

6) Try to reproduce the issue

 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component: