When trying to download the attachment from the OpenSpace 3.0, error "page cannot be displayed". However, upload of attachments works fine.

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Article ID: 35367

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Symptom:

When trying download the attachment from the OpenSpace 3.0, error "page cannot be displayed". However, upload of attachments works fine.

 

Environment: 

CA OpenSpace 3.0 which is on Public IP Address integrated with CA SDM R12.9 on Private IP Address on Windows 2008 Environment

 

Cause:

How upload of attachment from Open space works:

When users try to upload an attachment from OpenSpace, a web service call ‘CreateAttachment()’ is made to add an attachment to the CA SDM ticket.

 

How download of attachment from Open space works:

 The added attachment is added as a hyper link to the ticket in the CA SDM at the background. Clicking on the link tries to open the SDM UploadServlet URL to download the attachment file. If the UploadServlet is not accessible, users would not be able to download the attachment files.

 

Resolution/Workaround: 

The workaround is to publish the SDM URL to Public IP Address

 

 

Environment

Release:
Component: MA4SDM