Inbound synchronization of Identity Manager fails with ERROR: The environment: [environment name] does not have a domain-to-translator map for inbound synchronization.
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Inbound synchronization of Identity Manager fails with ERROR: The environment: [environment name] does not have a domain-to-translator map for inbound synchronization.

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Article ID: 35345

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Updated On:

Products

CA Identity Manager CA Identity Portal

Issue/Introduction

Inbound or outbound synchronization is failing in the environment and in the etanotify log or the application server log the following error is displayed: 

ERROR: The environment: [environment name] does not have a domain-to-translator map for inbound synchronization. 

 

Environment

Identity Manager 14.x

Cause

There are two possible root causes:

1) Some attributes have been mapped in IME settings and imported from an earlier IME that do not exist in directory.xmls

2) The inbound configuration is not correct.

Resolution

For inbound mappings, ensure all the defined attributes are indeed included in the directory XML files - both Corp and Prov sides. If an attribute has been renamed or removed during an upgrade, it needs to be removed from this section also.

To do so, from the Identity Manager Management interface, export both Directories, UserStore and Provisioning Directory, and check the XML files for the definition of the attributes. Please ensure only to map attributes used by Provisioning - the following mappings of IM Well-Known User attributes can be removed unless they have a specific use in your environment:
%ADMIN_OF%
%ADMIN_ROLE_CONSTRAINT%
%CERTIFICATION_STATUS%
%DELEGATORS%
%IDENTITY_POLICY%
%LAST_CERTIFIED_DATE%
%PASSWORD_DATA%
Removing these mappings will avoid unnecessary sync and call back operations between IM and IMPS for that particular attribute.

For Outbound configuration, see the details below on how to check that.

This issue can be caused by missing outbound mappings between Provisioning Server and IM and can be resolved by restoring the required mappings. 

In the Identity Manager Management Console go to Environments > [your environment] > Advanced Settings > Provisioning

The outbound mappings should contain at least the following: 

If any of these mappings are missing they can be added by selecting the user event and outbound event from the drop-down menus and hitting the add button. 

Once this is done click the save button and restart the environment. After the environment is restarted Inbound Sync should resume normal behavior.