nimSession - failed to connect session.error code 111 (Linux) or error code 10061 (Windows)
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nimSession - failed to connect session.error code 111 (Linux) or error code 10061 (Windows)

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Article ID: 35087

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

During startup of the Nimsoft robot, the Controller probe might report error code 111 or 10061 in the controller.log:

Windows OS

Controller error:

Apr  5 14:02:08:431 [1996] Controller: Controller on 5384631-2422648 port 48000 started
Apr  5 14:02:09:554 [1996] Controller: Hub <Hub> (###.##.##.##) contact established
Apr  5 14:02:10:584 [1996] Controller: nimSession - failed to connect session to ###.##.##.##:48001, error code 10061 Apr  5 14:02:11:598 [1996] Controller: nimPostMessage: sockConnect failed.

Linux OS

Controller error:

Mar 20 13:39:00:408 [139906982979328] Controller: Controller on ###.##.##.## port 48000 started
Mar 20 13:39:01:411 [139906982979328] Controller: Hub <Hub_name>(###.##.##.##) contact established
Mar 20 13:39:01:411 [139906982979328] Controller: nimSession - failed to connect session to xx.xxx.xxx.xxx:48001, error code 111 Mar 20 13:39:01:411 [139906982979328] Controller: nimPostMessage: sockConnect failed

This is part of normal operations, as the spooler has not had time to initialize yet. It happens if you turn audit on and when unable to send the audit message (I'm starting...) to the spooler, the controller will send the message directly to the hub.

Environment

Release: DX UIM, Any
Component: CAUIM

Cause

  • TCP error code 10061: No connection could be made because the target machine actively refused it. Generally, it happens that something is preventing a connection to the port or hostname. Either there is a firewall blocking the connection or the process that is hosting the service is not listening on that specific port.

Resolution

  • ​This is not an error and the messages can be safely ignored.

Additional Information

To validate there are no connection issues, ensure the probe shows as "green" in the IM console.

You can use the probe utility also to validate.

Using IM console, press CTRL-P with the controller highlighted.

In the probe utility, select "check_hub" and click the green arrow.