new install fails to start Nimsoft service Controller shows unknown

book

Article ID: 35046

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

Ater doing a clean install on of NMS server on a windows box NMS does not start.

The Nimsoft Controller program shows red and <unknown>

 

Cause

The screenshot would suggest that the Service was not created when the robot was installed.

Environment

Release: 7.X and newer
Component: CAUIM

Resolution

You can create the service manually by using the windows sc command.
Please attempt to create the service manually (process outlined here: http://support.microsoft.com/kb/251192). 

You will need to download the Windows 2008 recourse kit to get the sc utility.
The sc create command, creates an entry for the service in the registry and in the Service Control Manager database.

Syntax :
sc [Servername] create Servicename [Optionname= Optionvalue...
Try the following sc command which creates the service on the local computer as an auto-start service that runs in its own process:
sc create NimbusWatcherService binpath= "C:\Program Files (x86)\Nimsoft\bin\nimbus.exe" start= auto DisplayName= "Nimsoft Robot Watcher" depend= "tcpip" 

This should create the service for us on this system.
Once this is done, try to use the services MMC and start the service and let me know if it starts or not. 

Please also make sure if you have any antivirus installed that you have excluded the nimsoft directory from all scans.

Attachments

1558722621579000035046_sktwi1f5rjvs16wj1.jpeg get_app