NAS queue backed up and stops processing alarms and show a message in the logs" Command hubpost_bulk not in command-list in probe logs.
Problem is also seen post hub upgrade to 7.x, where some probes stop working
Example from Logmon profile using queue mode: Apr 13 20:05:57:465 [1992] logmon: RREQUEST: hubpost_bulk <-10.10.15.31/48002 h=236 d=9520 Apr 13 20:05:57:465 [1992] logmon: data bulk_size=1 bulk_list=PPDS(9467) qsize=1 Apr 13 20:05:57:465 [1992] logmon: Command 'hubpost_bulk' not in command-list Apr 13 20:05:57:465 [1992] logmon: SREPLY: status = 11(command not found) ->10.10.15.31/48002
Example from the nas probe logs Jul 30 12:23:14:097 [8924] nas: RREQUEST: hubpost_bulk <-10.10.10.91/48002 h=271 d=95007 Jul 30 12:23:14:097 [8924] nas: Command 'hubpost_bulk' not in command-list Jul 30 12:23:14:097 [8924] nas: SREPLY: status = 11(command not found) ->10.10.10.91/48002 Jul 30 12:23:14:199 [8924] nas: RREQUEST: hubpost_bulk <-10.10.10.91/48002 h=271 d=95007 Jul 30 12:23:14:199 [8924] nas: Command 'hubpost_bulk' not in command-list Jul 30 12:23:14:199 [8924] nas: SREPLY: status = 11(command not found) ->10.10.10.91/48002
Environment
Release: Component: UIMHUB
Cause
This is happening as Hub 7.x tries to disallow a bulk size of 1 and imposes a "floor" of 100 whenever it thinks the consuming probe supports that. Please upgrade NAS to latest supported version & hotifx level as well.
e.g., logmon was trying to make a connection to the hub. Because the hub was trying to force the connection to use a minimum bulk size of 100 it was causing a problem. By changing the hub to allow it to default back to 1 resolved the issue.
Resolution
To resolve this issue two new keys need to be added to the hub in raw config: