How to change the origin of Quality of Service (QoS) data already captured in the Unified Infrastructure Management (UIM) database
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How to change the origin of Quality of Service (QoS) data already captured in the Unified Infrastructure Management (UIM) database

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Article ID: 35037

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

It is sometimes necessary to change the Data Origin for QoS objects, as when robots have been moved.  There are two places to make changes in order to successfully change the origin 'ownership' of QoS data. The following instructions direct in how to modify your existing QoS data so it has the new origin value rather than the prior/old origin value.

Environment

Release: Any version
Component: CAUIM

Cause

The following steps were performed to change the Data Origin for a robot in your UIM environment:

Launch the controller probe configuration GUI for the robot whose origin you wish to change, navigating to the Setup/Advanced tab and supplying an override value in the Origin field of the Data Origin section (override origin set by the hub).  In the image below, you can see the Origin changed from robot1 to robot1_override.



NOTE - Changing the origin in this manner will result in previous QoS data persisting the original origin, and QoS data from after the change, having the new origin. 

Resolution

The following instructions explain how to modify your existing QoS data so it reflects the new origin value rather than the prior/old origin value.

Change the origin of a QoS through the SLM portlet Database Status dialog.

  1. Navigate to the SLM portlet in UMP (if not present in your UMP, create a new page and add the portlet to it). 
  2. Click on TOOLS and choose Database Status
  3. Hover your mouse over the name of one of the QoS that you want to change.  You will see a black dropdown arrow appear. 
  4. Click on the dropdown arrow and choose Change Origin.

You will see a screen such as this:



Click "Add" and add the new origin value used in the first step (the override set in the controller setup).

Choose the new origin and click "Ok".

Your origin should now appear as shown below with the newly chosen value.


Perform the same process for other QoS as needed.

NOTE - existing alarms will keep their old origin.  New alarms will now have the new origin.

If SLM is not a viable option for any reason you can use Mcrosoft SQL Server Studio (SSMS) or another databse tool to run queries to change/update the origin.

Essentially, you can run queries like:

SELECT * FROM S_QOS_DATA WHERE ORIGIN = '<OLD/BAD/WRONG ORIGIN_NAME>'

UPDATE S_QOS_DATA SET origin= '<new_origin_name>' WHERE origin ='<old_or_wrong_origin>' OR nim_origin = '<old_or_wrong_origin>'

Additional Information

How to update or change origins for QOS data?

https://knowledge.broadcom.com/external/article/144322

How to delete or merge old (obsolete) origins so they no longer display in IM or UMP

https://knowledge.broadcom.com/external/article/34704