Probes fail to start after a Robotname name change
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Probes fail to start after a Robotname name change

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Article ID: 35004

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

hdb and spooler probes appear red in Infrastructure Manager.

Environment

This applies to all systems where Robots can be installed.

Cause

Any change to the Robotname can cause the magic keys in the controller.cfg on the robot to need to be regenerated.

Changes that can trigger this include:

  • Changing the Robotname between uppercase and lowercase characters
  • Setting the Robotname manually in the controller
  • Changing between using the fully qualified DNS name and the shortname

This applies to all systems where Robots can be installed.

Resolution

To regenerate the magic keys, select the red probes in the Infrastructure Manager, right click and choose Security then Validate.  

Note that you may need to run this more than once due to probe dependencies.

If this does not work, do the following:

1. Stop the robot that has the problem probe(s)
2. Move the controller.cfg to the changes folder, remove all 
magic_key = <blank> lines
3. Restart the robot