After upgrading multi-instance UMP version to 7.5, Primary UMP shows 404 error

book

Article ID: 34997

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

As stated in the multi-instance UMP installation guide, when you uncomment the two new lines in the portal ext properties files:

cluster.link.enabled=true
lucene.replicate.write=true

And restart the primary UMP server in the browser you get the following 404 error:
HTTP Status 404 -
--------------------------------------------------------------------------------
type Status report
message
description The requested resource () is not available.
--------------------------------------------------------------------------------
Apache Tomcat/6.0.26

If you have the wasp loglevel set to 3 our higher you will see the following in the portal.log:

avr. 07 08:49:33:933 ERROR [main, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/]] listenerStart() Exception sending context initialized event to listener instance of class com.liferay.portal.spring.context.PortalContextLoaderListener
avr. 07 08:49:33:933 ERROR [main, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/]] org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'com.liferay.portal.kernel.cluster.ClusterExecutor' defined in class path resource [META-INF/cluster-spring.xml]: Invocation of init method failed; nested exception is java.lang.IllegalStateException: org.jgroups.ChannelException: unable to setup the protocol stack






 

 

Environment

Release:
Component: CAUIM

Resolution

To correct this issue you will need to add an additional Flag in the WASP GUI for the 'JV' (Java) options on the general tab.
-Djava.net.preferIPv4Stack=true
 

<Please see attached file for image>

WASP GUI
?
Please make sure to leave a space after the first entry.

This will also need to be done on the Secondary UMP WASP probe as well.

Once this is done, restart the primary WASP, wait for the port and pid to be assigned in the IM and then start the Secondary WASP and again wait for port and pid.

Both UMPs should now be accessible.

 

Attachments

1558689992758000034997_sktwi1f5rjvs16g5f.jpeg get_app
1558689989693000034997_sktwi1f5rjvs16g5e.jpeg get_app