Probe configuration (GUI) window opens in Raw Configure in IM
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Probe configuration (GUI) window opens in Raw Configure in IM

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Article ID: 34651

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

In Infrastructure Manager (IM), when I double-click on a probe instead of getting the normal probe GUI, I am getting a raw configuration screen or the probe gets a "stopped working" message, for example:

Probe GUI opens in Raw configure only

When the user requests a probe configuration tool (by double-clicking or right-mouse->configure on a probe), the Raw Configure tool appears instead of the probe-specific GUI.

How do I resolve this?

Environment

  • DX UIM 20.4.* / 23.4.*
  • Infrastructure Manager (IM) 4.10 / 20.4.* / 23.4.*

Cause

Different causes. Package file is missing / Missing permissions / User error

Resolution

Background: 
 
  • On each workstation running the Infrastructure Manager (IM), the configuration tool bits (GUI) for each probe are loaded (fetched) from the probe package (on the local archive) to the workstation and stored in C:\Program Files\Nimsoft\util on the local workstation.

  • For example, for cdm, the program would be conf_cdm.exe. Each time you ask for the configuration tool (double-click on the probe), the IM compares the version of the tool on your local workstation with the version in the Primary Hub's local archive and it will fetch a new version from the existing, local probe package if necessary.


To resolve the issue, check the following points: 

  1. Check if the probe package version exists in the local Archive.

    •  Check the contents of the archive directory. If the probe package file is missing, the IM will pop-up the Raw Configure window instead of the probe GUI. If the probe package does not exist in the local archive, download the probe package/version and import it into the archive. Then ensure that you have the correct hub address selected in Tools->Options in the Infrastructure Manager, e.g., the Primary Hub, and double-click on the probe again to see if it opens. 
     
    Note: that in the more recent versions of DX UIM, the directory used for the conf_<probe>.exe files are now util under Temp (you can check the variable by running set in a cmd window to see where TEMP is, e.g.,
     
    TEMP=C:\Users\<username>\AppData\Local\Temp).
    Usually C:\Users\<username>\AppData\Local\Temp\util
     
    Is there a copy of the tool there? Can the logged-in user write into that directory? Do they have Full Control?
    Some probes may also be located in the util folder under the Nimsoft home directory.


  2. In the IM try doing a SHIFT-double-click on the probe. This forces the IM to re-fetch the GUI tool from scratch, regardless of whether there is a copy on the local workstation or not. You should very briefly see a "fetching user interface for <probe_name>..." message box.

    There can be security issues with this action as the software tries to write to read-only files in these folders where the conf files sit.
    If that doesn't work you can copy the conf_<probe>.exe into the directory it's complaining about and try again.

    e.g.,

    C:\Users\Nusername>~1.HAS\AppData\Local\Temp/util/conf_<probe_name>.exe for write.

    Also check, does logging in as a Windows Administrator and opening the probes exhibit no issues at all?
    To resolve this issue, change permissions if necessary to allow writes into the directory that contains the configuration GUI's. (Full access)


  3. Is the workstation with the problem on a different network? (There may be a session ID problem -- we hash the IP address of the workstation and that might be different from the point of view of the login hub vs. the distribution server).

    Check that the package name for the probe has not been changed. This can be checked using the IM. Click on the robot so that the list of probes is in the upper right window. Scroll the list to the right until the package name column appears. Make certain the name in this column is the same as the name of the probe.

    Also, check the distsrv probe log on the login hub. At log level 1 or 2 you should see the get_configuration command asking for the probe configuration tool.

    Check the registry entries under HKEY_LOCAL_MACHINE\SOFTWARE\Nimbus Software\NimBUS Installation or \HKEY_LOCAL_MACHINE\SOFTWARE\WoW6432Node\Nimbus Software AS\NimBUS as shown here for 'Home':





  4. When you login to the IM make sure you have selected the correct IP address in the bottom of the window (Hub IP).

    Make sure that the probe package .zip is physically on the box and seen by the distsrv.
    Ensure that you have the correct hub address selected in Tools->Options in the Infrastructure Manager.

Additional Information

NOTE: Not all probes will have a conf_*.exe file associated with them. Probes that are not configurable via IM will not have one, e.g., discovery_server or mon_config_service.
If you are able to configure the probe via IM, but still don't see the conf_*.exe file, perform the following:

- open the configuration GUI in IM
- open Task manager and find the probe in the processes window
- right-click on the probe and click 'Open file location'

Sometimes the conf_*.exe files are put into a Temp directory instead of /nimsoft/util.

Location of probe configuration executables for GUIs are version specific, and must be present in the following location:

For example->  conf_<probe_name>_<version#>.exe,

C:\Users\Administrator\AppData\Local\Temp\2\util