Troubleshooting error code LCMVRLICONFIG40040 when upgrading VMware Aria Operations for Logs
search cancel

Troubleshooting error code LCMVRLICONFIG40040 when upgrading VMware Aria Operations for Logs

book

Article ID: 346007

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Upgrade of Aria Operations for Logs from Aria Suite Lifecycle fails with error as below:

  • The upgrade in Aria Suite Lifecycle will fail on stage 8 if Aria Operations for Logs is already at the version being upgraded to with an error in /var/log/vrlcm/vmware_vrlcm.log similar to:
      • Upgrade not needed as the version: 18.x-xxxx is the same as current
      • Aria Operations for Logs upgrade failed. Check if PAK/URL and the version provided are correct.
      • LCMVRLICONFIG40040

  • Within the /var/log/vrlcm/vmware_vrlcm.log you see messages similar to:
    2023-09-12 21:35:02.025 INFO [pool-3-thread-8] c.v.v.l.d.v.InstallConfigureVRLI - -- Return message for vrli: {"errorMessage":"The setup is not licensed for upgrade.","errorCode":"UPGRADE_ERROR"}
    2023-09-12 21:35:02.026 INFO [pool-3-thread-8] c.v.v.l.d.v.InstallConfigureVRLI - -- Return status code for vrli: 400
    2023-09-12 21:35:02.026 ERROR [pool-3-thread-8] c.v.v.l.d.v.InstallConfigureVRLI - -- The setup is not licensed for upgrade.
    2023-09-12 21:35:02.026 ERROR [pool-3-thread-8] c.v.v.l.d.v.InstallConfigureVRLI - -- Error while uploading pak file
    2023-09-12 21:35:02.026 ERROR [pool-3-thread-8] c.v.v.l.p.v.VrliPatchingTask - -- Exception while patching vrLI. pak file not found
    com.vmware.vrealize.lcm.common.exception.userinput.vrli.VrliUpgradeFileException: vRLI upgrade failed.
    2023-09-12 21:35:02.026 INFO [pool-3-thread-8] c.v.v.l.p.a.s.Task - -- Injecting task failure event. Error Code : 'LCMVRLICONFIG40040', Retry : 'true', Causing Properties : '{ CAUSE :: vrliPatchPakUrl === }'
  • During the upgrade process, instead of checking VMware Aria Suite Lifecycle Repository and let it autogenerate the repository url, the Repository URL is checked and /data was typed in the Repository URL field.

Environment

  • VMware Aria Suite Lifecycle 8.18.x
  • Aria Operations for Logs 8.18.x

Cause

  • This issue is observed due to various scenarios:
    • VMware Aria Operations for Logs has no active license.
    • The target version has already been installed from the Aria Operations for Logs UI.
    • Incorrect file location for the Repository URL.
    • Aria Suite Lifecycle fails or times out while waiting for the services to start and synchronize its inventory after the upgrade completes successfully, causing the request to fail.

Resolution

  • To resolve this issue validate the below checks:
    1. Ensure a valid VMware Aria Operations for Logs license is applied through VMware Aria Suite Lifecycle. Then, follow the correct upgrade sequence outlined in the product documentation.
    2. During the upgrade process, if the Repository URL is checked instead of VMware Aria Suite Lifecycle Repository and let it autogenerate the repository URL, make sure /data/product_upgrade.pak, /data/file_name.patch, /data/file_name.iso, etc. is typed in.
    3. Ensure you are upgrading to a newer release than the version of Aria Operations for Logs already in use.
    4. If this failure is encountered on stage 8, when retrying the failed request post encountering an error "LCMVRLISYSTEM45034", then:
      • Validate if Aria Operations for logs Is up and running on that node. If not, perform a quick reboot of that node in vcenter server after taking snapshots.
      • Once the Aria Operations for Logs UI is up, validate the upgrade is completed successfully and reflects the new version. 
      • If yes, ignore the failed upgrade request and trigger an inventory sync in Aria Suite Lifecycle for this Aria Operations for logs to update the Aria Suite Lifecycle inventory.

Additional Information

  • Impact/Risks:
    • Upgrade will fail unless active licenses are applied.