VMware Aria Automation onboarded VM's not getting pricing info in VMware Aria Operations
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VMware Aria Automation onboarded VM's not getting pricing info in VMware Aria Operations

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Article ID: 346003

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • VMware Aria Automation onboarded VM's should reflect pricing info in VMware Aria Operations.


Symptoms:
  • VMware Aria Automation onboarded VM's not getting pricing info in VMware Aria Operations.
  • We can see pricing info for other deployed VM's
  • Recreating the pricing card does not solve the issue


Environment

VMware Aria Automation 8.x

Cause

  • This can happen if when configuring VMware Aria Operations with VMware Aria Automation both applications are not set to same timezone.

Resolution

  • There is a workaround.


Workaround:
  • The workaround is to ensure when configuring VMware Aria Operations with VMware Aria Automation , ensure that both applications are set to the same timezone.
  1. Ensure to take proper snapshots of the VMware Aria Operations nodes. 
  2. Change the timezone in VMware Aria Operations to match that on VMware Aria Automation.
  3. SSH to the VMware Aria Operations primary node as root.
  4. Edit "$ALIVE_BASE/user/conf/analytics/advanced.properties" file:
vi $ALIVE_BASE/user/conf/analytics/advanced.properties
  1. Find this line "timeZoneUsedInMeteringCalculationand edit the existing entry to below:
timeZoneUsedInMeteringCalculation=US/Eastern
  1. Save the file
  2. Restart the analytics service on VMware Aria Operations: 
service vmware-vcops restart analytics
  1. wait for 24 hours to see if the metrics on vrops starts showing data


Additional Information

Impact/Risks:
  • VMware Aria Automation onboarded VM's will not get pricing info in VMware Aria Operations.