VMware Aria Suite Lifecycle keeps showing notifications for products patches/upgrades which are already installed
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VMware Aria Suite Lifecycle keeps showing notifications for products patches/upgrades which are already installed

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Article ID: 346002

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

VMware Aria Suite Lifecycle should NOT show notifications for products patches/upgrades which are already installed.

Symptoms:

  • VMware Aria Suite Lifecycle keeps showing notifications for products patches/upgrades which are already installed.

  • Inventory sync does not resolve the issue.

  • Clearing the notifications still sends new notifications after sometime on the UI. 

Environment

VMware Aria Suite Lifecycle Manager 8.x

Cause

This happens because there are old notifications schedules left over from earlier deleted environments on VMware Aria Suite Lifecycle, which do not show up in UI.

Resolution

The workaround is to find the notification schedules from old deleted (rogue) environment of the VMware Aria Suite Lifecycle and delete them.
 
Request to follow the below workaround:

1. Ensure proper snapshots and the backup of the VMware Aria Suite Lifecycle appliance and database. 

2. Login to the VMware Aria Suite Lifecycle as root.

3. Navigate to its database:

su - postgres

cd /opt/vmware/vpostgres/11/bin/

./psql -d vrlcm

4. Can see from the database that the old entries for environments does not exist in UI.

select environmentname from vm_lcops_environment;

 
5. An example of deleted/rogue environment is  'vRealize' and notifications are coming from this environment.

6. Find out the notifications from this old deleted environment by running query:

select vmid from vm_engine_scheduledrequest;

7. Delete the old notifications schedules (an example of the problematic notification schedule is 'vra,8.11.0,productPatchingNotification,vRealize'):

delete from vm_engine_scheduledrequest where vmid='vra,8.11.0,productPatchingNotification,vRealize';

8. Monitor the notifications on VMware Aria Suite Lifecycle UI for next 24 hours and it should not be triggered any longer.

Additional Information

Impact/Risks: No major impact.

In case when there is NO change observed after applying the above workaround, follow the steps below:

1. Retrieve the vmid of the problematic notification by running the following command:

select * from vm_notification;

2. Once you have the vmid, delete the corresponding entry using the following command:

DELETE FROM vm_notification WHERE vmid='xxxxxxxx';

Note: Replace 'xxxxxxxx' with the actual vmid retrieved from the previous query.