Aria Suite Lifecycle UI does not load and Postgres service is down because /storage is full
search cancel

Aria Suite Lifecycle UI does not load and Postgres service is down because /storage is full

book

Article ID: 345999

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

To increase the space on /storage for the Aria Suite Lifecycle appliance.


Symptoms:
  • Aria Suite Lifecycle UI does not load and stuck at waiting for services to start.
  • The postgres service on the Aria Suite Lifecycle appliance is down.
  • /storage partition on the Aria Suite Lifecycle appliance is full.

Environment

Aria Suite Lifecycle Manager 8.x

Cause

This happens because the /storage on the Aria Suite Lifecycle appliance is full and does not have enough space to load the Aria Suite Lifecycle services.

Resolution

 This can be resolved by increasing the space in the /storage partition in the appliance.

  1. Login as root to the Aria Suite Lifecycle Appliance

  2. Check the disk space utilization consuming high space: df -h

  3. Figured /storage was full and in /dev/sdc by running pvdisplay



    Note: Incase you have 2 disks with same storage size check by running lsscsi -v , this will show controller ID)

  4. Added more disk space to this drive from vCenter.

  5. Reboot the Aria Suite Lifecycle appliance.

  6. Aria Suite Lifecycle UI should be accessible now.

  7. Connect to the Aria Suite Lifecycle DB:

                      su - postgres
           cd /opt/vmware/vpostgres/11/bin
           ./psql -d vrlcm


 

      8. Run VACUUM FULL VERBOSE ANALYZE vm_rs_request; to clean up DB           

 

  1. Quit

  2. Exit

 

Note: All screenshots are from lab environment.  

Additional Information

Impact/Risks: Unable to login to the Aria Suite Lifecycle appliance UI.