Aria Suite LifeCycle Manager fails to check patch online and fails with error "PATCHREFRESH16006" "External Master patch Registry is corrupt."
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Aria Suite LifeCycle Manager fails to check patch online and fails with error "PATCHREFRESH16006" "External Master patch Registry is corrupt."

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Article ID: 345997

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

  • Aria Suite LifeCycle Manager fails to check patch online and fails with error "PATCHREFRESH16006"
  • LCM Logs shows handshake failure:
    c.v.v.l.d.p.h.PatchHelper - -- Exception while file download : handshake_failure(40 )

    INFO [pool-3-thread-40] c.v.v.l.u.RestHelper - -- url: https://vrealize-updates.vmware.com/vrlcm-200/patch MasterRegistry.json

    INFO [pool-3-thread-40] c.v.v.l.d.p.h.PatchHelper - -- Exception while file download : handshake_failure(40)

Environment

VMware Aria Lifecycle Manager 8.x

Cause

This can happen if customer environment has federal links which needs FIPS to be enabled to reach to the patch repository.

Resolution

Workaround: Enable FIPS on the LCM and retry to patch online.

  1. Take a snapshot of the LCM.
  2. Login to the LCM UI, select Settings > System Details > FIPS enabled (check the box) > Update
  3. This will enable the FIPS and reboot the LCM
  4. Once LCM is back online, try to fetch the Patch binaries again.