Inventory Sync fails with error ""INVENTORY_SYNC_QUEUE_REQUEST_FAILED" for Aria products in VMware Aria lifecycle manager
search cancel

Inventory Sync fails with error ""INVENTORY_SYNC_QUEUE_REQUEST_FAILED" for Aria products in VMware Aria lifecycle manager

book

Article ID: 345995

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

The inventory synchronization is failing with the error code "INVENTORY_SYNC_QUEUE_REQUEST_FAILED" and the exception "java.util.NoSuchElementException: No value present," as noted in the /var/log/vrlcm/vmware_vrlcm.log file.

Additionally, when selecting a product in the environment, it appears that the product information or the primary node is missing or null.

Environment

VMware Aria lifecycle manager 8.x

Cause

This issue may occur if the inventory synchronization fails due to invalid or incomplete environment information within the Aria Lifecycle Manager.

Resolution

Remove the Aria product from Lifecycle Manager Inventory and then re-import it back to Aria Lifecycle Manager. using the API call.

Workaround:

  1. Take snapshot of vRealize Suite Lifecycle Manager and its integrated products in the current state which your planning to remove. 
  2. In a web browser, navigate to https://vRSLCM-hostname/api/swagger-ui.html#/ and select spec as private internal API.
    Note: Replace vRSLCM-hostname with the hostname or IP Address of vRealize Suite Lifecycle Manager.
  3. Under Environment Controller, invoke the endpoint /lcm/lcops/api/v2/environments/globalenvironment/unsafe, with the following request body:
     { 

    "deleteFromInventory": true, 
    "deleteFromVcenter": false, 
    "deleteLbFromSddc": false, 
    "deleteWindowsVMs": false

      }

Screenshots below from LAB:

NOTE: Then change the deleteFromVcenter to false, we don't want to delete the VM from the vCenter as we
want to re-import the correct VIDM, that is why we need to make the changes to false.
  1. Once we go back to the vRSLCM environments dashboard, you will no longer see the global environments (VIDM), like where we can see environments but not the VIDM.
  2. Click Create Environment and Enable the toggle option for install/re-import option while creating the  environment, in next tab check the option IMPORT.
  3. Implement the Trigger inventory sync from all previous associated products to get product reference with VIDM.

Additional Information

Note: While we have provided an example using vIDM and the global environment, you can apply the same steps to any specific environment you wish to delete and re-import.